NoX Bomber Mod Generator

NoX Bomber Mod Generator Beta

Следуйте инструкциям, чтобы получить шестнадцатеричный модификатор для вашего Бомбера.

Теперь, выберите направление, куда будет смотреть бомбер:

Выберите, сколько заклинаний будет в бомбере(1-3):

Выберите заклинания, которые будут в бомбере:

Не забудьте, что бомберам необходимо указать свойство 'Enemy'!

Автор: Kirillius / KirConjurer


NoX Bomber Mod Generator

NoX Bomber Mod Generator Beta

Follow instructions to get an hexadecimal bomber's modifier.

Now, choose an bomber's direction:

Choose, how many spells must be on a bomber(1-3):

Choose spells, who must be on a bomber:

Don't forget that bomber's need the 'Enemy' property!

Author: Kirillius / KirConjurer


Click on a color to lock it.
Click on any square to unlock.

Red | Green | Blue

Low value's work too now.
Size of your colorlight (0-255)
Gradient amount (0-255)
pulse speed/delay (0-255)
banana


NoX Glyph Mod Generator

NoX Map Editor Glyph Mod Generator Beta

Follow instructions to get an hexadecimal Glyph modifier.

Now, how many spells must be on a trap(1-5):

Now, choose the trap spells:

Author: Kirillius / KIrConjurer


Here, you can create your own NPCs

Pick a color for your NPC :
Version : 3.0 - Remade with Javascript

Follow instructions below to get an hexadecimal modifier for a NPC.

The NPC must face in a direction. Choose it :

When an event occurs, a function can be called. You can set those functions below : for no reaction to an event, leave the field blank :

WhenGlobalAttackRestarted :

WhenDead :

WhenEnemyIsDetected :

WhenGlobalAttackStarted :

WhenHit :

UnknownEvent :

WhenTouched :

WhenEnemyIsInSight :

UnknownEvent2 :

WhenStartedMovingOrTargetDiedOrTargetVanished :

The utility of those bytes is still unknown. You´d better not edit them, unless you know what you´re doing.

- - -

Now, choose the NPC's colors :

Hair :

R G B

UnknownPart :

R G B

UnknownPart2 :

R G B

Beard :

R G B

UnknownPart3 :

R G B

Skin :

R G B

Enter an hexadecimal number (from 00 to FF) in each box. You NPC's class will be set by the middle box, and its behaviour by the two other boxes.

: - - : The current class of your NPC is : .

The utility of those bytes is still unknown. You´d better not edit them, unless you know what you´re doing.

- - -
- - -
- - -
- - -

Enter an hexadecimal number (from 00 to FF) in each box, to set your NPC´s vision range. Warning : not using default values may produce odd results.

: - - -

Enter a float to set your NPC´s aggresiveness (delimiter : "."). Zero will make the NPC peaceful, in any situation. Other values will produce different results : most used values are 0.5 and 0.83.

Here, choose the spells that your NPC will be able to cast, if he isn´t a Warrior. You can leave the spellset empty : if you do so,
and if your NPC is a Wizard or a Conjurer, make sure that he´s got a weapon, unless you want him to be a living harmless target.
"Secondary" spells are offensive spells that are casted twice less than "Primary" spells. They got the "[Secondary]" tag in the list.
To get the spells´ list and descriptions, click here.

Current spellset :
(empty)

The utility of those bytes is still unknown. You´d better not edit them, unless you know what you´re doing.

- - -
- - -
- - -
- - -
- - -
- - -
- - -

Enter an integer to set your NPC´s strength (max : 65535).

The utility of those bytes is still unknown (they may deal with NPC´s speed). You´d better not edit them, unless you know what you´re doing.

- - - - - -

The utility of those fields is still unknown. However, modifying their values is possible.

Choose what will your NPC do, when the map will load.

The utility of those bytes is still unknown. You´d better not edit them, unless you know what you´re doing.

- -

Make the NPC "unkillable" (can be wounded, but will never lose health).

The utility of those bytes is still unknown. You´d better not edit them, unless you know what you´re doing.

- - -

Enter an integer to set your NPC´s health (max : 65535).

The utility of those bytes is still unknown. You´d better not edit them, unless you know what you´re doing.

- - - - -

The second health value will be automatically set to the first health value.

The utility of those bytes is still unknown. You´d better not edit them, unless you know what you´re doing.

- - -

Enter a voice set for your NPC. You can pick one in the list below, or enter another you know.

:

The utility of those bytes is still unknown. You´d better not edit them, unless you know what you´re doing.

- - -

Don´t forget that NPCs need the "Pickup" property !

To report a bug, you can email me.

This script was made by "FF and Invisible Point"

Yeah, this script is totally from me...but a few values, and a part of the NPC knowledge were taken from RogueTeddyBear´s and Spiritus´ NPC Tutorial, thanks to them !

Back to main page


Horvath's Magical Glyph Generator.

This site is best viewed in 1024x768 resolution with 16-bit High Color.
Optimized for 4.X Web Browsers (Netscape and Internet Explorer Compatible)

~Glyph Generator

Glyph Generator

Glyph (Wizzie trap) object
How many spells in the trap.. (1-4)

Type spell 1
Type spell 2
Type spell 3
Type spell 4 (Update!)
Generate..
BETA version has limited amount of spells.
Possible spells:
SPELL_CONFUSE
SPELL_STUN
SPELL_SLOW
SPELL_BURN
SPELL_ANCHOR
SPELL_CHAIN_LIGHTNING
SPELL_CLEANSING_FLAME
SPELL_COUNTERSPELL
SPELL_DEATH
SPELL_DEATH_RAY
SPELL_DETONATE GLYPHS
SPELL_EARTHQUAKE
SPELL_FIREBALL
SPELL_FUMBLE
SPELL_LIGHTNING
SPELL_MAGIC_MISSLE
SPELL_MANA_BOMB
SPELL_METEOR
SPELL_METEOR_SHOWER
SPELL_NULLIFY
SPELL_PIXIE_SWARM
Updated, conjuror spells added!

Nox and Westwood Studios names are copyrighted by Nobody anymore. No rights reserved.
All images and screenshots of Nox are trademark Westwood Studios, 2000. All rights reserved. (NOT EA)

- Return to Top - Contact Us - Return to Home - Site Information -

Site Menu
Nox News
News Archives
 News Submission
Articles
Custom Maps
Nox Info
Client Download

Map Editing
Map editor
FAQ
Tutorials
Updates
Map Betas
Map Releases

Site Features
About Us
Discussion Forum
Other Links

Nox Reviews
For past reviews, click here.
DaGameBoyz (4 out of 5) [3/7/00]
Bloodshot (8 out of 10) [3/8/00]
Computer Games On-Line (4 out of 5 stars) [3/9/00]
HavenGames (95% out of 100%) [3/10/00]
The Adrenaline Vault (4 out of 5 stars) [3/11/00]
PC Gamer (89% out of 100%) [April 2000 Issue]

(Hecubah.com: The World of Oblivion))
(In Association with DiabloII.com: The Catacombs of Tristram)
(Visit Westwood Studios Today!)
(Webdog Community Tracker)
Nox Top 100


NoX Map Editor ModBox Generators
Maiden Mod Generator
Bomber Mod Generator(Русский)
Bomber Mod Generator(English)
Glyph Mod Generator
Other Mod Generators(under construction)
NoX Spells and Enchants List


NoX Maiden Mod Generator

NoX Maiden Mod Generator Alpha

Follow instructions to get an hexadecimal maiden's modifier

Choose maiden's direction :

Choose maiden's colors:

Hair :
Dress :
Dress top :
Skin :

Select a maiden's voice set:

Don´t forget that Maiden's need the "Enemy" property !

Author: Kirillius / KirConjurer


NoX Monster Mod Generator

NoX Monster Mod Generator Alpha

Следуйте инструкциям, чтобы получить шестнадцатеричный модификатор для вашего монстра.

Теперь, выберите класс монстра:

Выберите направление, куда будет смотреть монстр:

Выберите уровень агрессивности вашего монстра:

Выберите, что должен делать ваш монстр после того как карта загружена:

Не забудьте, что монстрам необходимо указать свойство 'Enemy'!

Автор: Kirillius / KirConjurer


NoX Map Editor Mod Generators

NoX Map Editor Other Mod Generators

Quiver
Введите количество стрел в колчане(макс.255):

Wands
Введите количество зарядов(макс.255):


NoX Map Editor Spells & Enchants List

NoX Map Editor Spells and Enchants List

Spells:

SPELL_INVALID
SPELL_ANCHOR
SPELL_ARACHNAPHOBIA
SPELL_BLIND
SPELL_BLINK
SPELL_BURN
SPELL_CANCEL
SPELL_CHAIN_LIGHTNING_BOLT
SPELL_CHANNEL_LIFE
SPELL_CHARM
SPELL_CLEANSING_FLAME
SPELL_CLEANSING_MANA_FLAME
SPELL_CONFUSE
SPELL_COUNTERSPELL
SPELL_CURE_POISON
SPELL_DEATH
SPELL_DEATH_RAY
SPELL_DETECT_MAGIC
SPELL_DETONATE
SPELL_DETONATE_GLYPHS
SPELL_DISENCHANT_ALL
SPELL_TURN_UNDEAD
SPELL_DRAIN_MANA
SPELL_EARTHQUAKE
SPELL_LIGHTNING
SPELL_EXPLOSION
SPELL_FEAR
SPELL_FIREBALL
SPELL_FIREWALK
SPELL_FIST
SPELL_FORCE_FIELD
SPELL_FORCE_OF_NATURE
SPELL_FREEZE
SPELL_FUMBLE
SPELL_GLYPH
SPELL_GREATER_HEAL
SPELL_HASTE
SPELL_INFRAVISION
SPELL_INVERSION
SPELL_INVISIBILITY
SPELL_INVULNERABILITY
SPELL_LESSER_HEAL
SPELL_LIGHT
SPELL_CHAIN_LIGHTNING
SPELL_LOCK
SPELL_MARK
SPELL_MARK_1
SPELL_MARK_2
SPELL_MARK_3
SPELL_MARK_4
SPELL_MAGIC_MISSILE
SPELL_SHIELD
SPELL_METEOR
SPELL_METEOR_SHOWER
SPELL_MOONGLOW
SPELL_NULLIFY
SPELL_MANA_BOMB
SPELL_PHANTOM
SPELL_PIXIE_SWARM
SPELL_PLASMA
SPELL_POISON
SPELL_PROTECTION_FROM_ELECTRICITY
SPELL_PROTECTION_FROM_FIRE
SPELL_PROTECTION_FROM_MAGIC
SPELL_PROTECTION_FROM_POISON
SPELL_PULL
SPELL_PUSH
SPELL_OVAL_SHIELD
SPELL_RESTORE_HEALTH
SPELL_RESTORE_MANA
SPELL_RUN
SPELL_SHOCK
SPELL_SLOW
SPELL_SMALL_ZAP
SPELL_STUN
SPELL_SUMMON_BAT
SPELL_SUMMON_BLACK_BEAR
SPELL_SUMMON_BEAR
SPELL_SUMMON_BEHOLDER
SPELL_SUMMON_BOMBER
SPELL_SUMMON_CARNIVOROUS_PLANT
SPELL_SUMMON_ALBINO_SPIDER
SPELL_SUMMON_SMALL_ALBINO_SPIDER
SPELL_SUMMON_EVIL_CHERUB
SPELL_SUMMON_EMBER_DEMON
SPELL_SUMMON_GHOST
SPELL_SUMMON_GIANT_LEECH
SPELL_SUMMON_IMP
SPELL_SUMMON_MECHANICAL_FLYER
SPELL_SUMMON_MECHANICAL_GOLEM
SPELL_SUMMON_MIMIC
SPELL_SUMMON_OGRE
SPELL_SUMMON_OGRE_BRUTE
SPELL_SUMMON_OGRE_WARLORD
SPELL_SUMMON_SCORPION
SPELL_SUMMON_SHADE
SPELL_SUMMON_SKELETON
SPELL_SUMMON_SKELETON_LORD
SPELL_SUMMON_SPIDER
SPELL_SUMMON_SMALL_SPIDER
SPELL_SUMMON_SPITTING_SPIDER
SPELL_SUMMON_STONE_GOLEM
SPELL_SUMMON_TROLL
SPELL_SUMMON_URCHIN
SPELL_SUMMON_WASP
SPELL_SUMMON_WILLOWISP
SPELL_SUMMON_WOLF
SPELL_SUMMON_BLACK_WOLF
SPELL_SUMMON_WHITE_WOLF
SPELL_SUMMON_ZOMBIE
SPELL_SUMMON_VILE_ZOMBIE
SPELL_SUMMON_DEMON
SPELL_SUMMON_LICH
SPELL_SUMMON_DRYAD
SPELL_SUMMON_URCHIN_SHAMAN
SPELL_SWAP
SPELL_TAG
SPELL_TELEPORT_OTHER_TO_MARK_1
SPELL_TELEPORT_OTHER_TO_MARK_2
SPELL_TELEPORT_OTHER_TO_MARK_3
SPELL_TELEPORT_OTHER_TO_MARK_4
SPELL_TELEPORT_POP
SPELL_TELEPORT_TO_MARK_1
SPELL_TELEPORT_TO_MARK_2
SPELL_TELEPORT_TO_MARK_3
SPELL_TELEPORT_TO_MARK_4
SPELL_TELEPORT_TO_TARGET
SPELL_TELEKINESIS
SPELL_TOXIC_CLOUD
SPELL_TRIGGER_GLYP
SPELL_VAMPIRISM
SPELL_VILLAIN
SPELL_WALL
SPELL_WINK
SPELL_SUMMON_CREATURE
SPELL_MARK_LOCATION
SPELL_TELEPORT_TO_MARKER

Enchants:

ENCHANT_INVISIBLE
ENCHANT_MOONGLOW
ENCHANT_BLINDED
ENCHANT_CONFUSED
ENCHANT_SLOWED
ENCHANT_HELD
ENCHANT_DETECTING
ENCHANT_ETHEREAL
ENCHANT_RUN
ENCHANT_HASTED
ENCHANT_VILLAIN
ENCHANT_AFRAID
ENCHANT_BURNING
ENCHANT_VAMPIRISM
ENCHANT_ANCHORED
ENCHANT_LIGHT
ENCHANT_DEATH
ENCHANT_PROTECT_FROM_FIRE
ENCHANT_PROTECT_FROM_POISON
ENCHANT_PROTECT_FROM_MAGIC
ENCHANT_PROTECT_FROM_ELECTRICITY
ENCHANT_INFRAVISION
ENCHANT_SHOCK
ENCHANT_INVULNERABLE
ENCHANT_TELEKINESIS
ENCHANT_FREEZE
ENCHANT_SHIELD
ENCHANT_REFLECTIVE_SHIELD
ENCHANT_CHARMING
ENCHANT_ANTI_MAGIC
ENCHANT_CROWN
ENCHANT_SNEAK

Author: Kirillius / KirConjurer